WAMP mostra erro ‘MSVCR100.dll’ está faltando quando instalar

Quando tentei instalar o WAMP , apareceu o seguinte alerta, MSVCR100.dll está faltando

Eu cliquei em OK , ele continuou a instalar o WAMP. Quando eu começo, o logo do WAMP é sempre ‘amarelo’. Não está ficando “verde”, o que significa que há algo errado. O que exatamente é o arquivo MSVCR100.dll ? Como posso obtê-lo e corrigir esse erro?

    O arquivo MSVCR100.dll é parte do Microsoft Visual C++ , redistribuíveis. Você pode instalá-los e ver se isso resolve o seu problema. Depois de instalar, verifique se a instalação do wamp está configurada corretamente. Procure por “meu ícone wamp fica laranja” postagens.

    Este artigo nos fóruns do WampServer mostra todas as bibliotecas de tempo de execução do Microsoft Visual C ++ que você precisa ter instaladas em seu sistema para cada versão do WampServer. Citar:

    Para Windows 32: Certifique-se de ter instalado o pacote redistribuível do Visual C ++ 2010 SP1 x86: VC10 SP1 vcredist_x86.exe

    http://www.microsoft.com/download/en/details.aspx?id=8328

    Para Windows 64: Certifique-se de ter instalado o Pacote Redistribuível do Visual C ++ 2010 SP1 x64: VC10 SP1 vcredist_x64.exe

    http://www.microsoft.com/download/en/details.aspx?id=13523

    O Apache não será executado sem esse componente

    Na verdade, se você estiver executando o Windows de 64 bits, é uma boa idéia instalar todas as bibliotecas de 32 bits, bem como as de 64 bits. Afinal, as janelas de 64 bits executam códigos de 64 e 32 bits. Você provavelmente vai achar que precisa de pelo menos um dos tempos de execução de 32 bits para algum aplicativo / utilitário que você instalará em algum momento.

    ATUALIZAR

    Se você estiver executando o WAMPServer 2.5, também precisará do redist VC11. Visual C ++ redistribuível para o Visual Studio 2012

    29.08.2014 com o WAMP 2.5 Concordo que o VC11 é necessário e não é uma má idéia ter distribuições anteriores instaladas. Será necessário por outro aplicativo. Eu não tenho certeza se você precisa de uma versão 32 bits

    http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679

    ATUALIZAÇÃO 3 de agosto de 2016

    Como fui informado por Fred -ii- (muito obrigado, por sinal) o link para o post nos fóruns wamp não funciona mais. Como não consegui encontrar o link original, você pode tentar http://forum.wampserver.com/read.php?2,138295 . Tem muita informação e pode ajudá-lo.

    Para mim, nenhuma das respostas acima funcionou, então estou adicionando o que funcionou para mim. Instalei pela primeira vez os arquivos mencionados na resposta aceita e quando isso não funcionou, baixei os arquivos deste link e ele começou a funcionar.

    Então eu acho que a distribuição de 2012 também é necessária (estou usando window7 home basic 64 FYI).

    Eu resolvi este problema instalando este aqui: http://www.microsoft.com/en-sg/download/details.aspx?id=30679

    Certifique-se de remover o wampserver e reinstalá-lo novamente

    Nota: estou usando o Windows 7 32 bits

    Eu tentei todas as respostas acima, mas ainda o mesmo erro foi vomitando. Mais tarde eu encontrei isso no WAMP Forum e finalmente meu WAMP funciona !!!

    Se você estiver usando o WampServer 2.5 em um Windows de 64 bits Você precisará das versões de 32 bits e 64 bits desse tempo de execução.

    Microsoft Visual C ++ 2012 (www.microsoft.com)

    Pressione o botão Download e, na canvas seguinte, selecione VSU_4 \ vcredist_x86.exe. Pressione o botão Download e, na canvas seguinte, selecione VSU_4 \ vcredist_x64.exe

    Fonte: http://forum.wampserver.com/read.php?2,123608

    Na maioria das vezes você terá que instalar o x86 e x64!

    Links aqui: x86 e x64

    Eles são o pacote redistribuível do Visual C ++ 2010 SP1

    (aconteceu comigo ao instalar o MySQL Workbench)

    Apenas corri nesta questão. Problema foi no mesmo sistema operacional (Win7 HB x64) como nesta resposta . Eu usei o conselho do gaurav e iniciei o WAMP com sucesso.

    Eu queria adicionar que você não precisa de versões do Visual C ++ 2010 ao usar a versão 2012 (pelo menos neste caso).

    Eu instalei o novo WAMP 2.5, eu tenho o Windows 8 x64 bits. Eu tentei todas as soluções acima, mas não funcionou comigo e o ícone do WAMP permanece laranja . a coisa que funciona comigo é:

    1. desinstalar o atual bit x64 WAMP
    2. instalar este http://www.microsoft.com/pt-br/download/details.aspx?id=30679
    3. Baixe e instale o servidor WAMP para x32 bits.
    4. Escolha o Firfox como o navegador.

    Espero que eu ajude alguém a procurar por esta resposta

    Edit: Desde que eu encontrei o mesmo problema novamente, tenho notado que a minha solução anterior não funcionou; bem como qualquer outra solução publicada aqui. Eu estou usando o Windows 7 Professional (64 bits).

    Dessa vez, coloquei o arquivo ‘MSVCR100.dll’ (baixado como um arquivo ZIP, depois extraí para o Desktop e copiei) em uma pasta C: \ Windows http://www.dll-files.com/dllindex/dll- files.shtml? msvcr110

    e, em seguida, o instalador WAMP Server, 64BIT. http://sourceforge.net/projects/wampserver/

    Em seguida, baixei e instalei: http://www.microsoft.com/en-us/download/confirmation.aspx?id=30679

    nome do arquivo: vcredist_x64.exe

    Eu só testei com o PHP a partir de um prompt de comando , já que eu faço todo o resto em um servidor e não em um host local.

    Embora funcione para o que eu preciso usar

    Corrida:

    php dá falha ao carregar php_xdebug-2.2.5-5.5-vc11.dll

    php -v -WORKS!

    Por favor, deixe-me saber se isso funcionou para você ou não, ou se há outra coisa que eu preciso fazer para melhorar a correção.

    Hoje eu instalei o servidor Wamp 3.0.6 (x64) em uma máquina Windows 10 com o VS2017 instalado. Eu tinha muitos pacotes redistribuíveis do Visual C ++ instalados, mas não o 2012. Então eu instalei e agora posso rodar o servidor Wamp. Você pode encontrar um link de download aqui .

    Se você não entender nada, faça o download do vcredist_x86.exe em http://www.microsoft.com/en-us/download/details.aspx?id=8328 . Isso resolverá seu problema.

    Re / instalar o framework .NET não funcionou para mim. Alguns soft wares menos profissionais, como os utilitários de otimização, manipulam ou mantêm constantemente em uso os arquivos do .NET Framework. assim .dll. Aprendi enquanto tentava desinstalar as atualizações do .NET antes da reinstalação.

    • Não se esqueça de desinstalar o wamp do painel de controle antes de reinstalá-lo.
    • Desinstalando atualizações do Windows no .NET. (controlPanel-> desinstalar um
    • program-> view updates) Desinstalando soft wares que impede
    • desinstalar o .NETs. Terminado com sucesso a desinstalação do .NET
    • atualizações do framework. Verifique as atualizações do Windows. Instale as atualizações que aparecem após a verificação (atualização do .NET Framework. 3update para mim em win7x64)
    • instale o wamp (terminou de forma impecável para mim)

    Passo 1. Desinstalar o WAMP

    Etapa 2. Instalar a última atualização do Microsoft Visual C ++ 2015 Redistributable 3

    Etapa 3. Reinicie o Sistema

    Etapa 4. Reinstale o WAMP

    Verifique se o Skype não está conectado. Você não quer saber detalhes se você é um novato 🙂

    Para mim, o problema não resolveu mesmo depois de instalar redistribuições do VC ++. Eu tive que baixar manualmente o arquivo MSVCR110.dll de https://www.dll-files.com/msvcr110.dll.html e colocou-o em c: /> windows> system32 e funcionou corretamente.

    Esta ferramenta irá verificar a falta de pacotes e também lhe dará link de download para os pacotes. .
    Se você está no Windows 64 bits, então você precisa instalar ambos os pacotes x86 e x64
    link para baixar a ferramenta:

    DOWNLOAD

    Para resolver este problema, você tem que instalar todos os pacotes de redistribuição da Microsoft 2010,2012 (x86 e x64) do que desinstalar o wampserver do painel de controle e reinstalar a nova cópia do servidor wamp. Esse erro será corrigido

    Instalar apenas vcredist_x64.exe do Visual C++ Redistributable for Visual Studio 2012 corrigiu o problema para mim.

    https://www.microsoft.com/pt-br/download/details.aspx?id=30679

    Estou usando o Windows 7 Home Basic 64 bit e instalei o WampServer 2.5

    Eu encontrei esse problema quando meu sistema operacional estava em francês e eu estava instalando o Wampserver em inglês.

    Tenho certeza de que os pacotes Microsoft Redistributable foram instalados desde que eu já estava trabalhando com o Visual Studio. Eu acho que o problema pode ter sido por causa de mudanças em nomes de caminho com diferentes idiomas. No entanto, quando eu instalei wampserver em francês, tudo funcionou perfeitamente.

    Depois de baixar todas as bibliotecas ditas por ezaoutis, a mensagem de erro no meu windows 10 persistiu, lendo os requisitos de instalação do wampserver3.1.3 , havia uma ferramenta de verificação chamada check_vcredist.exe , eu corri e mostrei todas as bibliotecas que faltam e é download links, então eu finalmente poderia instalá-lo com sucesso.

    Abaixo da imagem com a ferramenta de verificação marcada

    Eu tive o mesmo problema, mas nenhuma das respostas acima funcionou. Veja o que fez o trabalho para mim:

    1. baixe msvcr110.dll , msvcr120.dll , msvcp120.dll e vcruntime140.dll de dll-files.com
    2. Copie-os no System32
    3. Desinstalar wamp
    4. Reinstale o wamp

    Algumas vezes você tem que instalar todas as versões ou um monte delas.

    Quem não encontrou acima respostas úteis, dê uma olhada aqui