É possível usar o derby do apache no Eclipse agora que eles pararam de desenvolver o plugin derby para o Eclipse?

Eu gostaria de usar o Derby do apache para include o gerenciamento de database em um aplicativo de desktop que estou desenvolvendo atualmente.

Infelizmente eu descobri que eles pararam de desenvolver este plugin e todos os tutoriais que eu li online se referem a este plugin.

Então, minha pergunta é, como posso usar a última versão do Derby no eclipse? Quais etapas devo seguir? Eu gostaria que meu aplicativo fosse autônomo e facilmente transferível.

desde já, obrigado

O Apache Derby é como outros bancos de dados que fornecem interface por meio do JDBC. Você não precisa de um plugin específico para se conectar ao Derby. Apenas use as rotinas comuns do JDBC.

Passos básicos:

  1. Se você quiser usar a versão mais recente do Derby, primeiro você precisa baixá-la daqui
  2. Você precisa include o jar no seu classpath.
  3. Você só precisa fazer conexões e executar consultas usando o JDBC, conforme explicado melhor no Oracle JDBC Tutorial .

Ditto Pram.

Estou usando o Derby em um aplicativo Java que estou desenvolvendo com o Eclipse e não sabia que havia um plug-in. Eu me conecto ao Derby como faria com qualquer outro database. Eu uso a interface de linha de comando do Derby para gerenciar as tabelas. \

(Um recurso de outros bancos de dados que eu gostaria de ver no Derby: ter extensões SQL para exibir metadados db, como os comandos “mostrar” e “descrever” do MySql. O Derby os tem na interface da linha de comando, mas eles aparentemente são implementados lá, e não no próprio mecanismo SQL, portanto, não é possível usá-los fora da CLI.Quando estou desenvolvendo, costumo criar uma canvas de consulta ad hoc no aplicativo que me permite digitar e executar consultas arbitrárias. (E não, eu não implantar isso em sites públicos.) Mas eu discordo.

Eu não sei o que o plug-in faz por você. Nunca usei um plug-in do Eclipse para nenhum database.

O plug-in ainda está disponível no formato de origem e as instruções para criá-lo estão disponíveis no site do Derby: http://svn.apache.org/viewvc/db/derby/code/trunk/plugins/eclipse/Readme.txt ? view = markup

De tempos em tempos as instruções para construir a mudança de plug-in; talvez você queira verificar o status desse problema para obter mais atualizações: https://issues.apache.org/jira/browse/DERBY-5272