Migrando Angular 4.x para Angular 5

Eu li os seguintes blogs e documentação

  • Blog Angular
  • Jacaré IO Docs
  • Documentação Oficial

e sem informações claras sobre como migrar de 4.x para 5.

Tentei os seguintes comandos

Nada funcionou bem para mim. Por favor ajude

Você precisa atualizar todos os pacotes fornecidos pelo angular para suas versões mais recentes da seguinte forma:

 npm install typescript@2.4 --save-dev npm install @angular/common@latest @angular/compiler@latest @angular/compiler-cli@latest @angular/core@latest @angular/forms@latest @angular/http@latest @angular/platform-browser@latest @angular/platform-browser-dynamic@latest @angular/platform-server@latest @angular/router@latest @angular/animations@latest --save 

Isso deve fazer todo o necessário. Além disso, você também pode atualizar seu cli angular que vem com o angular 5 como versão padrão, como segue:

 npm uninstall -g @angular/cli npm cache clean npm install -g @angular/cli@latest 

Aqui está o blog oficial da equipe Angular: https://angular-update-guide.firebaseapp.com/ . Este guia de atualização ajudará você a migrar de qualquer versão para a mais recente.

Este site tornou muito fácil para mim. Coloque a sua versão da qual você está atualizando e para qual você está atualizando. Meu aplicativo é simples, por isso pode depender da complexidade do seu aplicativo.