bootsrap nav-bar recolhível não pode fazê-lo funcionar

Eu estou desenvolvendo um aplicativo Angularjs e eu gostaria de fazer multiplataforma então para fazer isso eu estou tentando usar o Bootsrap, eu encontrei um modelo que eu gostaria de seguir ( https://blackrockdigital.github.io/startbootstrap -business-frontpage / # ) o problema é que eu quero transformar a navbar quando o tamanho da canvas é menor.

insira a descrição da imagem aqui

insira a descrição da imagem aqui

mas eu não sei o que estou perdendo, porque faz corretamente a transformação para um botão, mas então, o botão não é clicável, então as opções ‘inicio’, ‘servicios’ e ‘contato’ são inacessíveis.

Qualquer ajuda seria incrível, aqui você tem os arquivos css e html:

HTML

      HOME                   

Copyright © Your Website 2014

CSS

 /* * Start Bootstrap - Business Frontpage (http://startbootstrap.com/) * Copyright 2013-2016 Start Bootstrap * Licensed under MIT (https://github.com/BlackrockDigital/startbootstrap/blob/gh-pages/LICENSE) */ body { padding-top: 50px; /* Required padding for .navbar-fixed-top. Remove if using .navbar-static-top. Change if height of navigation changes. */ } /* Header Image Background - Change the URL below to your image path (example: ../images/background.jpg) */ .business-header { height: 400px; background: url('http://placehold.it/1920x400') center center no-repeat scroll; -webkit-background-size: cover; -moz-background-size: cover; background-size: cover; -o-background-size: cover; } /* Customize the text color and shadow color and to optimize text legibility. */ .tagline { text-shadow: 0 0 10px #000; color: #fff; } .img-center { margin: 0 auto; } footer { margin: 50px 0; } 

EDIT Eu criei um Jsfidlle https://jsfiddle.net/txominsirera/v8ups1hc/

Tanto o jQuery quanto o Bootstrap.js devem ser incluídos no jQuery colocado antes do Bootstrap.js .

Nota: A versão do jQuery que pode ser usada irá variar dependendo da versão do Bootstrap sendo usada (ou vice-versa).


Bootstrap Version 4

JS Muitos dos nossos componentes requerem o uso de JavaScript para funcionar. Especificamente, eles exigem jQuery , Popper.js e nossos próprios plug-ins de JavaScript. Coloque os seguintes s perto do final de suas páginas, logo antes da tag de fechamento >, para ativá-los. O jQuery deve vir primeiro, depois o Popper.js e nossos plugins JavaScript.

Nós usamos o build slim do jQuery , mas a versão completa também é suportada.


Para o Release v4.0.0-beta.2 package.json

 "peerDependencies": { "jquery": "1.9.1 - 3", "popper.js": "^1.12.7" }, 

Bootstrap Version 3

jQuery obrigatório

Observe que todos os plug-ins de JavaScript exigem que o jQuery seja incluído, conforme mostrado no modelo inicial . Consulte nosso bower.json para ver quais versões do jQuery são suportadas.

Para o lançamento v3.3.7 Changelog & bower.json

 "dependencies": { "jquery": "1.9.1 - 3" } 

Para v3.3.6 bower.json

 "dependencies": { "jquery": ">= 1.9.1 - 2" } 

Para v3.3.0 - v3.3.5 bower.json

 "dependencies": { "jquery": ">= 1.9.1" } 

Isso não conta para o lançamento do jQuery v3.0


Para v3.0.0rc1 - v3.2.0 bower.json

 "dependencies": { "jquery": ">= 1.9.0" } 

Isso não conta para o lançamento do jQuery v3.0