Articles of macos

Yosemite e Valgrind

Você pode me dizer como instalar o valgrind no yosemite? Quando eu tento instalá-lo eu fico “verificando a versão do kernel … sem suporte (14.0.0) configure: erro: Valgrind funciona em Darwin 10.x, 11.x, 12.xe 13.x (Mac OS X 10.6 / 7/8/9) ” Não há nenhum caminho oficial ou atualização, e eu não encontrei nada (exceto […]

Instalou o Java 7 no Mac OS X, mas o Terminal ainda está usando a versão 6

Eu instalei o JDK 7u7 baixado do site da oracle. Mas após a instalação, o terminal ainda está mostrando a versão 6 do java $java -version java version “1.6.0_35” Java(TM) SE Runtime Environment (build 1.6.0_35-b10-428-11M3811) Java HotSpot(TM) 64-Bit Server VM (build 20.10-b01-428, mixed mode) alguma idéia porque o java 7 não está aparecendo? Resp: OK, […]

Qual é o erro “Instrução Ilegal: 4” e por que “-mmacosx-version-min = 10.x” o corrige?

Recebo Illegal Instruction: 4 erros com binários compilados com o GCC 4.7.2 no Mac OS X 10.8.2 (“Mountain Lion”), quando esses binários são executados no Mac OS X 10.7.x (“Lion”) e em versões anteriores. Os binários funcionam corretamente no Mac OS X 10.8.x. Eu adicionei -mmacosx-version-min=10.5 aos meus flags de compilation e isso parece ajudar […]

Biblioteca de estrutura do OS X não carregada: ‘Imagem não encontrada’

Eu estou tentando criar um básico OS X Framework, agora eu só tenho uma estrutura de teste criada: TestMacFramework.framework e estou tentando importá-lo em um novo projeto de aplicativo OS X. Eu construí o arquivo .framework e importei para o novo projeto, A estrutura parece link bem, e eu posso referenciar o arquivo de header […]

grep -P não funciona mais como posso rewrite minhas pesquisas

Parece que a nova versão do OSX não suporta mais o grep -P e, como tal, alguns de meus scripts param de funcionar. var1=`grep -o -P ‘(?<=).*(?=)’ file.txt` Eu preciso capturar o grep para uma variável e eu preciso usar as asserções de largura zero. bem como \ K var2=`grep -P -o ‘(property:)\K.*\d+(?=end)’ file.txt` Quaisquer […]

Como construir um arquivo dmg Mac OS X (em uma plataforma não-Mac)?

É possível construir um arquivo .dmg (para distribuir aplicativos) de uma plataforma que não seja do Mac? E se sim, como?

Como escrever o plugin do OS X Finder

Estou procurando um guia ou código de exemplo para escrever plugins do Mac OS X Finder? Gostaria de saber como fazer algumas ações simples: adicionando superposições de imagem aos icons adicionando itens do menu de contexto ouça as alterações nos arquivos Eu encontrei os dois resources a seguir: Escrevendo Plug-ins de Menu Contextual para o […]

Executando um comando em uma nova janela do Mac OS X Terminal

Eu tenho tentado descobrir como executar um comando bash em uma nova janela do Max OS X Terminal.app. Como exemplo, aqui está como eu executaria meu comando em um novo processo bash: bash -c “my command here” Mas isso reutiliza a janela de terminal existente em vez de criar uma nova. Eu quero algo como: […]

A class JavaLaunchHelper é implementada em ambos… libinstrument.dylib. Um dos dois será usado. Qual deles é indefinido

Fiz upgrade para o Java 7 u40 mais recente no MacOS X e comecei a receber a seguinte mensagem no console ao ativar meu aplicativo usando o Eclipse. O aplicativo funciona bem, mas eu gostaria de descobrir a causa do problema e esperançosamente uma correção para ele. objc[10012]: Class JavaLaunchHelper is implemented in both /Library/Java/JavaVirtualMachines/jdk1.7.0_40.jdk/Contents/Home/bin/java […]

Rails 3 – não é possível instalar o pg gem

Quando eu tento executar o pacote (bundle install), eu sempre consigo Installing pg (0.13.2) with native extensions Gem::Installer::ExtensionBuildError: ERROR: Failed to build gem native extension. /Users/ryan/.rvm/rubyes/ruby-1.9.2-p290/bin/ruby extconf.rb checking for pg_config… no No pg_config… trying anyway. If building fails, please try again with –with-pg-config=/path/to/pg_config checking for libpq-fe.h… no Can’t find the ‘libpq-fe.h header *** extconf.rb failed […]